Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Thread Tools Search this Thread
Old Feb 11, 2004, 6:56 PM   #1
Junior Member
Join Date: Feb 2004
Posts: 4
Default Update on the Optio 33 WR problems

After explaining to the Pentax rep the problems with colour distortion on two seperate 33 WR's, he said to try a different SD card. I tried a new card this weekend and took about 60 shots in a variety of different situations with a variety of different modes, all in high res. The results....

Some shots came in without any colour distortion. Especially with bright background and close subject that was not moving, nor too small to be properly focussed on. Some shots with dark and white ( whitewater in a river canyon) came back blury but with no colour distortion (the speed necessary to freeze water was not possible without pushing the camera out of it's programmed comfort zone).

The shots that were taken in portrait and in picture mode came back with colour distortion again. Unfortunatly these were the only pictures that were clear and well focused. So, it isn't the card as well.

After some 800 plus shots with two different 33 WR 's, three print shops, and two different SD cards , it seems that the camera just can't do action shots in a wet environment. Sad really since this is a water resistant camera for the outdoor enthousiast.

Steepcreeker is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 9:17 PM.