Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Thread Tools Search this Thread
Old Sep 27, 2005, 7:18 AM   #1
Junior Member
Join Date: Sep 2005
Posts: 4

Whats up with the release of this model.
Sigmeister is offline   Reply With Quote
Sponsored Links
Old Oct 2, 2005, 9:25 PM   #2
Junior Member
Join Date: Aug 2005
Posts: 8

Don't know, but Best Buy is taking orders and saying it is back-ordered.
danbee46 is offline   Reply With Quote
Old Oct 4, 2005, 12:07 PM   #3
Junior Member
Join Date: Aug 2005
Posts: 17

I see a lot of smaller camera shops seem to have it listed as in stock, but not major online or department retailers.¬* ¬* ¬*A friend told me to look into it back in August, and I've been watching Amazon.com, and originally they said September 10, and now it still says "In Stock Soon" since¬* the last week of August.I might as well just go for the new Canon A610 or something. ¬* ¬*
spooie is offline   Reply With Quote
Old Nov 10, 2005, 7:47 PM   #4
Senior Member
propwash's Avatar
Join Date: Aug 2004
Posts: 277

I saw one in Wal-Mart last weekend. It looked nice and compact, but I'm not sure about putting 6 million pixels in such a small sensor. BTW, the display model they had was broken--the flash was disabled (flash lightning bolt symbol with diagonal line through it), and it could not be enabled with the multifunction key. I'm sure that, like most display models, it was abused by all the people playing with it. It still looks like a nice package,however.

(Edited Novermber 24) I was back in the same store yesterday, and now the flash was working again. The first time I was there and it wasn't working, we tried unplugging the power supply cord (the display model has no batteries installed) for a few minutes to try to get a system reset, but it did not make any difference. The flash still would not work. Yesterday, however, it was working just fine. I know it was the same camera as before, and the sales person said he didn't remember anyone doing anything to try to fix the flash. I don't know how it got fixed by itlsef.

Anyway, with the flash working properly, the camera seemed to take pretty good pictures. The color looked good, not to saturated, and the camera is pertty intuitive to use.

propwash is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:32 PM.