Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Pentax

Thread Tools Search this Thread
Old Apr 9, 2006, 5:07 PM   #1
Junior Member
Join Date: Apr 2006
Posts: 1

I took out my S5I today to take a pcture, the GReen "Ready" light, the red "recording" light, and the self timer light are all on constant. The power button is glowing amber. When press power, the camera will not turn on. The LCD panel will not illuminate, it won;t take pictures, the lense won't come out, it is totally dead.

Is there a way to "reset" the camera? It has not been dropped or abused. It worked fine one week ago, the battery was low, so I charged it. My wife then picked it up, put it in the case, and put it back in her purse. Now it won't work... I am thinking maybe a button was pushed in her purse and the thing is locked up, but I can't find a reset button-

I have tried taking the battery out and re-charging it on the cradle itself, I have tried taking the SD card out, and I have tried putting the camera on the cradle w/o the battery, and when it gets power in each case, I get the same results. I tried plugging it in to the USB cord thinking that might trigger something to reset- but no luck.

I would like to think that I won't need warranty repair, but I am afraid that may be the road I need to go down-

Any help is appreciated-
faustin01 is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:50 PM.