Go Back   Steve's Digicams Forums > Post Your Photos > Photo Critiques

Thread Tools Search this Thread
Old Aug 7, 2005, 8:33 PM   #1
simonknutson's Avatar
Join Date: Jun 2005
Posts: 74

I took firework pictures for the first time over the weekend. I am pretty happy with the results, though not sure what the usual settings would be for such pictures. I used shutter priority mode and set the exposure for between 6 and 20 seconds. This shot: ISO50, f/9, 10 seconds. Any comments, suggestions, techniques welcomed as I'm hoping to see some more this weekend.

Attached Images
simonknutson is offline   Reply With Quote
Sponsored Links
Old Aug 8, 2005, 1:54 AM   #2
Super Moderator
Hards80's Avatar
Join Date: Nov 2004
Location: Cleveland, OH
Posts: 9,046

other than cropping off the top fireworks, you have a good shot here.. the shutter speed choice was good and it was good to use a low ISO to keep out the noise.. i would say this was a good first attempt indeed..
Hards80 is offline   Reply With Quote
Old Aug 11, 2005, 12:46 PM   #3
Senior Member
Join Date: Jul 2004
Posts: 1,724

Very nice...can't wait to see the next batch. Best regards,

KENNETHD is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:03 AM.