Go Back   Steve's Digicams Forums > Printers > Photo Inkjet

Reply
 
Thread Tools Search this Thread
Old Jan 19, 2008, 5:42 PM   #1
Member
 
Join Date: Aug 2004
Posts: 48
Default

My Canon i650 started acting up and is not printing properly. Thought nozzles plugged and did cleaning: no help. Took head out and did flushing with water and alcohol, reinstalled: no help. Took head out again and cleaned electrical contacts on back of head with an eraser. Reinstalled: works great. But after about 50 4 x 6 prints, acted up again Same problem and same solution, worked alright. Again after a number of prints, stopped printing properly again.
After each disassembly, cleaning and reinstalling of the print head, did nozzle check and head alignment and everything indicated all was well and in fact worked for a little while again.
What is happening?

Also, the ink monitor does not seem to be working. Checked the monitor (through the Control Panel) and says there is ink (about 1/8 in a couple of tanks). But after a few prints, color is way off. Physically check the tanks and they are empty. Monitor never came up automatically like it has been doing and notifying that ink is low. What is happening here now?

Any clues with all this?

Thank you
Gritty is offline   Reply With Quote
Sponsored Links
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:08 PM.