Go Back   Steve's Digicams Forums > Printers > Photo Inkjet

Reply
 
Thread Tools Search this Thread
Old Apr 1, 2008, 11:46 AM   #1
Junior Member
 
Join Date: Apr 2008
Posts: 3
Default

I have a strange problem that's left me scratching my head, see if you can figure this one: When I print from my Canon i960 onto either Epson Photo Quality Paper or Epson Glossy Photo Paper, the coloris very magenta-toned.However - and here's the weird part -it will match my monitor display color accurately when I print on plain paper. Of course, the cheap paper doesn't allow much detail as the ink tends to soak in and bleed. But the color's good!

I'm printing from Photoshop CS2on a Mac G5 workstation with a 23"Apple cinema display, OS X 10.4.1. Test pattern printout looks fine, and I recently removed and cleaned the entire ink cartridge bay using a solution of water and rapidograph pen cleaner (which works amazingly well, by the way). The only thing I can think of is that I'm using generic ink, possibly not the same kind as I used the last time I tried to print quality photos (I usually use it to to print simple composite documents, text, etc.).

This is a recent development, I used get good results from pretty much any quality photo paper.

Any suggestions would be appreciated...thanks!
stee1962 is offline   Reply With Quote
Sponsored Links
Old Jan 14, 2009, 6:00 PM   #2
Junior Member
 
Join Date: Jan 2009
Posts: 2
Default

Did you ever get an answer to this or figure out the problem? I'm having the same issue. Didn't have the problem before but it's consistent now...any paper other than plain paper gives me either an orange or magenta tint. I've tried tweaking settings, re-installing drivers, etc. No luck.
brabin is offline   Reply With Quote
Old Jan 14, 2009, 6:04 PM   #3
Junior Member
 
Join Date: Apr 2008
Posts: 3
Default

Hey brabin...

I'm afraid I hit a dead end on that one. Such a weird one to troubleshoot. I even thoroughly cleaned my jets with a micxture of water and technical pen cleaning fluid, which usually works. Wish I had better news...if I figure it out I'll ping ya...
stee1962 is offline   Reply With Quote
Old Jan 14, 2009, 7:30 PM   #4
Junior Member
 
Join Date: Jan 2009
Posts: 2
Default

I was afraid of that.

I think it must be driver related, not printer head or nozzles, since the plain paper colors are fine.

I'll keep digging too and post if I learn something.
brabin is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 9:59 AM.