Go Back   Steve's Digicams Forums > Printers > Photo Inkjet

Reply
 
Thread Tools Search this Thread
Old Jul 1, 2004, 8:51 PM   #1
Junior Member
 
Join Date: Dec 2002
Posts: 7
Default

Help! My Epson Photo 960 was printing fine until tonight.I replaced the Magenta cartridge with an OEM Epson cartridge. I ran the cleaning utility 4 times. Ran the nozzle check. One of the black grids is barely visible, and none of the yellows are. Do I need new print heads? Should I just buy a new printer?

Thanks.
Jeff P is offline   Reply With Quote
Sponsored Links
Old Jul 17, 2004, 1:27 AM   #2
Junior Member
 
Join Date: Jul 2004
Posts: 4
Default

I had problems with my Epson Printers clogging their heads and sometimes doing too many cleaning cycles makes things worse. I tried searching for unclogging Epson printers in Google and found some websites that had helpful info on unclogging the heads but I had to go through a lot of trouble, I made windex cleaning cartridges and I also taped up paper towels folded to about 1/2" wide to the area that the print head crosses over and soaked it and passed the head over it untill it was free of ink to help. sometimes you can soak the pad where the printhead parks with windex or distilled water and unclog the head but I got fed up with the constant clogging and threw out my 870 a couple of days ago. And bought a Canon but try this web page before you give up. http://www.eddiem.com/photo/printer/unclog/unclog.html
Waydb is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 5:23 PM.