Go Back   Steve's Digicams Forums > Software > Printing General

Reply
 
Thread Tools Search this Thread
Old Dec 7, 2010, 3:11 PM   #1
Junior Member
 
Join Date: Dec 2010
Posts: 1
Default Epson R300 Will not print

Printer is 5/6 years old. It prints ok using run of the mill copy paper. and i made calendars and greeting cards last year using 160 and 210 GSM photo paper and matte. Bought from reputable suppliers. Right now, as soon as I start print job, on 160 GSM paper, it will not feed, I get either error message, 'Paper Jam' or 'Paper not loaded correctly.' after several tries it finally works ok. However when I change to 201 paper it takes a dozen tries to print one Item. I cant find any bits of dirt or paper in the feed, have blown it out with Air, but still the same. I have tried several paper qualities from differnt manufacturers, but still same prob. Any suggestions please?
Laserblue10 is offline   Reply With Quote
Sponsored Links
Old Dec 9, 2010, 4:15 PM   #2
Senior Member
 
VTphotog's Avatar
 
Join Date: Mar 2005
Location: Extreme Northeastern Vermont, USA
Posts: 4,212
Default

My best guess would be the rubber rollers which feed the paper have gotten slick from wear/dust accumulation/ age glazing. Sometimes, cleaning with alcohol will cure the problem, at least temporarily. You may need to get some cleaning sheets to run through it. I think Epson sells them on their website, or you should be able to get them from most suppliers.

brian
VTphotog is offline   Reply With Quote
Old Dec 9, 2010, 4:25 PM   #3
Senior Member
 
gjtoth's Avatar
 
Join Date: Nov 2007
Location: Louisville, KY, USA
Posts: 6,931
Default

Did you set it up in the software for the heavier paper?
__________________
Gary ---- "The best camera is the one you have with you."
<><~~~~~~~~~~~
Pentax K-70 ~ Panasonic FZ1000
My Gallery

--
Hebrews 13:3
gjtoth is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:13 PM.