Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Ricoh

Thread Tools Search this Thread
Old Mar 6, 2007, 10:02 PM   #11
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,370

Stranger things have been known to fix cameras.

See the 4th post on this page from a Minolta Z3 owner.

Edited -- I missed posting the link. Here it is:


...still laughing as I write this. So angry off that my Z3 was broken and I was going to have to splash out more cash on another camera I threw it down the stairs.

... and now it works!!!

JimC is offline   Reply With Quote
Old Mar 29, 2007, 9:42 AM   #12
steve's Avatar
Join Date: Jun 2002
Posts: 2,535

steve is offline   Reply With Quote
Old Sep 27, 2013, 3:36 PM   #13
Junior Member
Join Date: Sep 2013
Posts: 1
Default Perfect Manual for Caplio G4 Lens error, EINZIG perfekte Reparaturanleitung

Originally Posted by usaum View Post
Hi all,

i have had the same problem, same error code. After using the RR30 for 15 month i had to send it back for servicing. I hoped for a warranty repair but i was wrong. 127 Euro they wanted to have.

The error code 00-00-28 or something like that is NOT a firmware problem. It is a shame that ricoh service advices an update to somebody with such an error.

It is the OBJEVTIVE (i dont know if this is the right english word) ...the lens system!

Since i did not want to pay that money i gave it a try myself. I de-assembled the camera (6 little screws in the chassis). It is kind of hard to take the 2 parts of the chassis apart afterwards. The turnwheel on top seems to stuck. Press down the trigger and push the 2 parts apart. It works. Then you will find another 5 or 6 screws around the lens system. Take it out. Move the objective manually. Push the On botton until you hear the lens motors working. (there are some sensors inside the objective. they monitor the lens position). Play around, putting the objective back inside and out until it moves automatically, turning the little black wheel on the side manually if it doesent, ...etc. Soon you will see that the objective moves in and out again, as before, no error code will appear anymore. Put the parts together again (5 minutes as max) Your cam is working again.

Fuck Ricoh service!

Regards from Germany

Hello Uwe,
your Instruction was perfect. I did it exactly like you wrote, took out the lense (5 srews) and turning the little wheel beside until the lense mechanism worked easy again. Then I reinstalled the lense by the 5 screws by trying some Lens positions. And suddenly it worked again. Absolutely perfect !!

Und nebenbei gesagt, bin auch aus Germany. Witzig, dass wir uns über dieses Forum gefunden haben.

Many greatings from Germany

Trino is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:49 AM.