Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sanyo

Thread Tools Search this Thread
Old Oct 27, 2009, 12:31 AM   #1
Junior Member
Join Date: Oct 2009
Posts: 1
Default Xacti VPC-CA65 lcd is blank

A couple of weeks ago, the LCD on my Xacti VPC-CA65 started getting blurry and not displaying the colors correctly. A few days ago, the LCD went completely white. Photos and videos are still ok when I view them from my PC. I'm considering replacing the LCD. Has anyone experienced this behaviour before and has anyone replaced the LCD?


andreasp is offline   Reply With Quote
Sponsored Links
Old Oct 27, 2009, 10:40 PM   #2
Senior Member
subc's Avatar
Join Date: Oct 2007
Location: California, Sac area
Posts: 261

I have no idea how to go about this, and most likely it would cost more to replace the LCD than to replace the camera itself.
Regardless, I think I will slow down with the use and abuse I place on my CG65, seeing from your experience how they also die from usage. Thanks and good luck!
That's like.. your opinion man
subc is offline   Reply With Quote
Old Jan 1, 2010, 6:20 AM   #3
Junior Member
Join Date: Jan 2010
Posts: 1

That same problem just happened to my Xacti VPC-CA65 EXW. First the display showed false colors and low resolution, then (after two days) it went completely blank. Pictures and mp4 are as good as usual. But the camera is of very limited use if the display does not work. I posted a question at Sanyo Support today.
furacoco is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:04 PM.