Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Sony Alpha dSLR / Konica Minolta dSLR, Sony SLT

Thread Tools Search this Thread
Old Apr 20, 2007, 5:41 PM   #11
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,372

kberntsen wrote:
To be fair, I was comparing a x50 to and x133 card but both should have been faster than the camera could write. Maybe not. :-)
Even Kingston's standard cards test much faster than most Kingston Elite Pro 50x card in a KM DSLR. Heck, I've got one old 4x (not 40x) Lexar card that's roughtly 4 times as as fast as a Kingston Elite Pro 50x in my KM 5D. lol To be fair, this one Lexar is pretty fast. I think they mislabled it.

Anyway, the problem with the Elite Pro 50x cards appears to be a compatibility quirk of some kind.

They work OK in many devices, just not KM DSLR models.

The same issue occured with many of the Elite Pro 50x cards in KM Ax series cameras, too (depending on the edge stamp of the card and when/where it was made). Some of them are *dramatically* slower than most other cards, even standard speed cards in some of these Ax series cameras (for example, the DiMAGE A1)

You'll also see problems trying to use them in Kodak DSLR models.

JimC is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:02 PM.