Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Sony Alpha dSLR / Konica Minolta dSLR, Sony SLT

Thread Tools Search this Thread
Old Dec 16, 2010, 12:32 PM   #1
Junior Member
Join Date: Dec 2010
Posts: 1
Default Minolta Maxxum 4 not turning on..

Hi all, I have a problem!!
I was given a Canon powershot last Xmas and love it, so much that I haven't touched my Minolta maxxum4 since then. I of course forgot to take the batteries out, I kept meaning to, just got busy.
So Xmas is coming and I want some nice shots and decided to give the Minolta a clean and check it out. Well it doesn't turn on, I get the flashing battery sign in the display. I cleaned the battery contacts. I checked the 3v batteries and both have a full charge like new, and my dh checked the volts which are also at full +.

Could the batteries still not work because they've been sitting too long? I've tried turning off/on repeatedly like the manual suggests, but no luck. Does this mean my camera is dead now?? It worked fine last year, before it sat unused.

Anyone have any insight??

jelo is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:50 PM.