Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Sony Alpha dSLR / Konica Minolta dSLR, Sony SLT

Thread Tools Search this Thread
Old May 31, 2006, 8:47 AM   #1
Junior Member
Join Date: May 2006
Posts: 3

I bought a new Minolta 5D with the hope of using the old lenses from my Maxxum 7000. Well every lens works fine except one, the Sigma. It is a 70 to 210 zoom and when it is onthe camera body and I try to use it the body say's no lens installed. I called Minolta and they said we don't recommend anyone using any other lenses but Minolta brand. (imagine that). I was wondering if anybody else ever ran across this problem and what they did. I tried using the camera in the manual mode but I still get the same reaction. If anybody could give me some advice (other then go buy a new lens)on how to get this lens to work I would really appreciate it.
chryslerbill is offline   Reply With Quote
Sponsored Links
Old May 31, 2006, 9:42 AM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,369

Sigma reverse engineers the lens mount technology, so sometimes you find a Sigma lens with a compatibility problem (since Sigma missed things in the protocol between the camera and lens). This is a rare problem with anyone elses lenses (since apparently, they do license the lens mount protocol).

Sometimes, Sigma can rechip a lens so that it's compatible (usually at no charge except for return shipping), depending on the lens (some can be updated, and some can't).

Contact Sigma or CHRIS and give them information about your lens (model, serial number) and they should be able to tell you if it can be updated.

If it can't be updated (some Sigma lenses can't), you can tell the camera to release the shutter with no lens attached (with drawbacks like no AF or aperture control).

Look for an option for "Shutter Lock" in your setup menus and turn it off to allow the camera to work with no lens attached (which is what it will think with an old Sigma with a compatibilty problem).

From Sigma's web site:

Sigma Corporation of America
15 Fleetwood Court
Ronkonkoma, NY 11779

To request assistance by phone in the US, our technicians are available from 9AM to 5PM Eastern Standard Time, Monday through Friday. Please call: (631) 585-1144.

Customer Service Department call toll free (800) 896-6858.

You can also fax us 24 hours a day.
Fax: (631) 585-1895 or (631) 585-7661

E-mail: info@sigmaphoto.com

For your convenience, your Sigma product may also be serviced at:

Authorized Sigma Service Center:

250 N. 54th Street
Chandler, AZ 85226
e-mail: cris@criscam.com
Tel: 480 940-1103
Fax: 480 940-1329

Store hours: 9:00 AM - 5 PM, M-F Pacific Standard time

JimC is offline   Reply With Quote
Old May 31, 2006, 1:40 PM   #3
Junior Member
Join Date: May 2006
Posts: 3

Thank you very much, I'll get all the information off of the lens and give them a call tomorrow. Once again thank you............
chryslerbill is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:14 AM.