Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Sony Alpha NEX

Thread Tools Search this Thread
Old Sep 21, 2011, 6:26 PM   #1
Junior Member
bludebkk's Avatar
Join Date: Sep 2011
Location: West Palm Beach
Posts: 8
Default NEX 5N, Firmware Issue (Mac)

Hello everybody. I'm Blu. This is my first time here. I've just gotten my new NEX 5N today. It has been a long 3 days wait. Everything is perfect. I set everything according to my preferences BUT one last thing, Update the Firmware. I downloaded the V4. The computer doesn't recognize the camera. A window kept telling me to turn the camera off, remove the battery and restart the process. It came with V1.

Any idea? All advises are welcome.

Thanks, Blu

Update: Just chatted with a Sony rep. whom I think I can inform him a thing or two about the camera!!! Any how, there is no upgrade Firmware for the 5N. That's what he told me. The 5N came with V1, so I think that means...that's it.

Last edited by bludebkk; Sep 21, 2011 at 7:07 PM.
bludebkk is offline   Reply With Quote
Sponsored Links
Old Sep 21, 2011, 7:36 PM   #2
Senior Member
TCav's Avatar
Join Date: Sep 2005
Location: Washington, DC, Metro Area, Maryland
Posts: 13,394

Yours is the NEX-5N. That firmware is for the NEX-5. They're different, and that firmware won't work on yours.

BTW, everything in that firmware update, and more, is already in your 5N.
  • The lens is the thing.
  • 'Full Frame' is the new 'Medium Format'.
  • "One good test is worth a thousand expert opinions." - Tex Johnston, Boeing 707 test pilot.
TCav is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:27 AM.