Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old May 1, 2007, 9:40 AM   #1
Junior Member
Join Date: Jun 2006
Posts: 3

Hi all!

I have a problem with my Sony P200 that I haven't noticed before, although I barely used it before…

Photos taken have a few dark spots on them – these are constant at their place and are much sharper and noticeable when using the 3x zoom than when shooting wide angles, although still smeared. At a wide angle the spots are mostly only noticeable against a uniform background.

I guessed it must be something on the lens, although I couldn't see anything wrong with it, so I tried cleaning it with a glasses' lint and then again more thoroughly, but it didn't help.

I searched here and found someone mentioning a dust issue with this camera, but I'm not sure how to try and get it out without making things worse.

Unfortunately, I'm outside the country and Sony would only suggest taking it to their shop, which it out of the question right now, and in any case it would not be covered by warranty.

I have attached a cropped piece of a photo taken at full telephoto.

What are the chances that dust is the issue? Should I try blowing air into it? Could anyone suggest how and where?

Thanks in advance for any of your thoughts or suggestions!
Attached Images
lllll is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:00 PM.