Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Oct 28, 2008, 8:39 AM   #1
Junior Member
Join Date: Oct 2008
Posts: 1

I just learned an expensive lesson and I wanted to share it with you.My wife's sony dsc-v1 wouldnot register any battery life and would shut down after 2 minutes use.I replaced battery and then charger still wouldn't work.I sent it out for repair at the cost of 140 dollars.They recalibrated and reloaded software.I put in mem stick and still wouldn't read any battery life.I returned to repair facility and they went through it again no cost.When I put mem stick back in same trouble.I then had the bright idea to try a differant mem stick and you guessed it it works fine.I had never heard of mem sticks going bad so I never bothered to check.I hope this may help someone avoid a 200 dollar lesson goin forward.
mvsuds is offline   Reply With Quote
Sponsored Links
Old Oct 28, 2008, 8:58 AM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,371


I've moved this thread down to our Sony Forum, since it's a Sony specific issue. Yes, I've seen that issue before with a defective Memory Stick (apparently, failing in a way that's probably causing it to pull too much current, or shorting out something in the camera).

JimC is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:03 AM.