Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old May 28, 2010, 7:16 PM   #1
Junior Member
Join Date: May 2010
Posts: 2
Default Alpha 100 not recognizing a 500mm mirror lens

Hi gang,
I took a chance on a Phoenix 500mm mirror lens just to see if I could live with the limitations but I can't even get my A100 to recognize it. Any advise on settings I may be missing? I didn't want to send it back without at least TRYING to shoot with it.
Lundegaard is offline   Reply With Quote
Sponsored Links
Old May 28, 2010, 7:53 PM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,367

Welcome to the forums.

Those lenses are cheap for a reason. ;-)

That's a fixed aperture lens with no Autofocus, and no electronic communication with the camera at all. So, the camera isn't going to recognize that you have a lens on it.

You can still get it to work.

You'll just need to go into the custom settings menus and set Shutter Lock to Off (so it will still take a photo even if it doesn't see a lens attached). See this page for more info on custom settings:


If you have a problem after setting shutter lock to off, try setting Priority Setup to Release (so that it will shoot without any focus lock).
JimC is offline   Reply With Quote
Old May 28, 2010, 7:58 PM   #3
Junior Member
Join Date: May 2010
Posts: 2
Default Rock on!

Thanx mon frer, I'll give those a shot.

Yah, I read some pros & cons on this lens & thought I'd try it anyhoot. It kinda sounded like it behaved like the old Nikkor 200mm prime I trained on 25 years ago so maybe I could deal with the finicky focus. We'll see tomorrow when I have some sunlight to play with...

Thanx again!
Lundegaard is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:34 AM.