Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Dec 8, 2003, 1:36 PM   #1
Junior Member
Join Date: Dec 2003
Posts: 2
Default Sony DSC-S85 and WINDOWS 2000

My Windows 2000 laptop used to recognize my SONY DSC S85, but somehow that information was lost, and now I have trouble making the two work together. When I plug the SONY into the laptop's USB, I usually do not see it as an additional drive on the computer, as it used to be.
When I reinstall the driver, I often get an error message that I have unplugged the device improperly, suggesting that the computer did see hte camera, but somehow did not recognize it as a drive.

Is there an updated WINDOWS 2000 driver for this star-crossed camera?
venik is offline   Reply With Quote
Sponsored Links
Old Jan 18, 2004, 12:42 PM   #2
Junior Member
Join Date: Nov 2003
Posts: 3

I don't know if this will help, but I never installed the software that came with my P-10. I turned on the camera, plugged it into the usb port, and win 2000 recognized a new piece of hardware and did a set-up on its own. I was then able to read the card in the camera as a removeable drive, and was able to edit and save back to the memory stick.

When I unplug the camera, I do get a message saying that I disconnected a piece of hardware. I ignore the message and have had no problems.

So.....you may want to try removing the hardware and simply connecting the camera to the computer.
Jimwsea is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:54 PM.