Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Sep 29, 2010, 1:36 PM   #1
Junior Member
Join Date: Sep 2010
Posts: 1
Default good day to all.

I recently found a camera that was given to my husband from his old boss. The camera is maybe 4-5 years old. It is a Sony cybershot DSC-T1.
After looking at it I realized it needed a new battery which I have purchased and after charging it and replacing with the old one I have tried endlessly to get this camea programed. I have probably put 5 hours into it and still can't get it. The camera turns on, but the screen arae has never shown the area of interest that I am trying to take a picture of. The screen does show, how many minutes left on the camera,date, and numerous other icons. The camera even flashes when I take a photo( even though I can't see where it is) but I am not taking any photos as I have placed the card into a reader and everything is blank. I would apprecaite any help. My husband says I should throw it away but I am sure I must be missing something. Can you help? Thanks
parealtor313 is offline   Reply With Quote
Sponsored Links
Old Sep 30, 2010, 8:50 AM   #2
Senior Member
mtclimber's Avatar
Join Date: Oct 2005
Location: Oregon, USA
Posts: 18,143


Welcome to the Forum. We're pleased that you dropped by.

I hate to be the bearer of bad news, but from your description, it appears that the T-1 camera is defective. It is not something that a user can fix. Sony Service is about the only option, and that will be rather expensive.

Sarah Joyce
mtclimber is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:29 PM.