Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Feb 7, 2012, 2:39 PM   #1
Junior Member
Join Date: Feb 2012
Posts: 1
Default Sony Dsc-h10 Capacitor not charging


I bought a brand new Sony Digital DSC-H10 camera in 2008. The Flash stopped working in 2011.
I am not a camera tech. I ordered replacement part from Sony and replaced the entire flash board after sustaining many initial high voltage shocks.
The flash did not work. Some forums suggested the capacitor could be faulty hence I ordered a new capacitor from Sony and replaced/soldered it carefully.
I gave the capacitor 2-3 days to charge up. I also touched the capacitor leads to check if the capacitor was charged (I decided to endure another shock) But no the capacitor is not charging.
The flash strobe pops up but does not flash. This tells me that 1) the capacitor is not faulty 2) The Flash board is not faulty 3) The camera battery has no problems 4) The camera works fine without the flash
Here is the issue: Something is preventing the Capacitor from charging. Maybe the circuit board or some other channel.

What could be the problem ? Is it possible to jump start the capacitor some other way internally ?

Please advise. Much appreciated.
Chagas is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:29 AM.