Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Dec 1, 2013, 4:57 PM   #1
Junior Member
Join Date: Dec 2013
Posts: 1
Default Faulty/worn On/Off buttons

Hi, this is my first time on the forum.
I think the Sony W130 ( mine is a pink one) is a super little camera. I received mine as a present four years ago and it has worked faultlessly, until a few weeks ago, when it was reluctant to switch ON. However, after pressing the button sever times, it suddenly switched on and the lens slid out as normal.
When I had finished taking pics,. I had to press the Off button several times before These days I have to tap it, shake it, tap it again and some times it will switch ON and sometimes not. I know the battery is good! Do you think it is a faulty/worn out switch or a sticking zoom motor? Are they repairable? I shall keep it anyway because it was a present. Any suggestions welcome,
Thank you, Olivia.
Halgavorlass is offline   Reply With Quote
Sponsored Links
Old Dec 2, 2013, 3:36 PM   #2
Senior Member
Join Date: Sep 2011
Location: Bangor,North Wales
Posts: 3,691

Perhaps the on button is indeed worn..
Try pressing the playback button/viewing button from off- just to view a pic- and then a wee tap of the shutter button to wake it into shooting mode- as opposed to the usual firing up method...
SIMON40 is offline   Reply With Quote
Old Dec 3, 2013, 2:13 PM   #3
Senior Member
Join Date: Jan 2011
Location: Australia, New South Wales central coast
Posts: 2,808

G'day Olivia

On / Off buttons - like a pair of well loved shoes - do wear out eventually

My original Fuji camera lasted about 5 years and 90,000 images before the on /off button started to misbehave ... & it worked to its own schedule for a while before I had no choice but to look for a replacement

Hope this helps
Regards, Phil
Has Fuji & Lumix superzoom cameras and loves their amazing capabilities
Google me at Travelling School of Photography Australia
Recent images at http://www.flickr.com/photos/ozzie_traveller/sets/
Ozzie_Traveller is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 12:28 AM.