Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Feb 29, 2004, 4:34 PM   #1
Junior Member
Join Date: Feb 2004
Posts: 1
Default Sony DSC P51 help............

I purchased a Sony DSC P51 about 14 months ago and it has worked flawlessly. Well last night while taking pictures, the images started comming out blury. It wasn't a probelm with the settings or shutter speed as they were set correctly. I turned the camera off and then back on. Well it came back on but with nothing in the display. It was just black, but everything else seeme to work. It is like there is something covering the lense (but nothing is). So I take the memory stick out and stick it into my computer and there are photos on there, but they are just all black. I know it would cost more to get it fixed than the camera is worth. Has anyone here had any luck dealing with sony or ciruit city? I know this is a common problem as I have seen many other post with the same problem on another board - http://www.expansys.de/forumthread.a...ON590&thread=4 . . When does a common issue turn into a recall? Or am I just waisting my time?
brianp316 is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:35 PM.