Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Nov 4, 2004, 2:45 PM   #1
Junior Member
Join Date: Nov 2004
Posts: 1

i have the t11 from sony...i noticed that there is a gap/space between the LCD monitor and the Casing for the camera. I have another sony digicam and compared it, the LCD and camera casing was Flush leaving no gaps in between. This gap on my T11 or T1 for some of you can lead to dust or debris accumulation on our camera, resulting maybe in malfunction or worse going to the service center sooner for repairs. the gap is quite substantial and really suprised that sony overlooked this fault. In my case the gap is bigger on one part of the screen compared to another side of it. For some owners this can be just a small defect that can easily be set aside and just say 'FORGET ABOUT IT' but for example you go to a beach and fine sand starts creeping onto that space between the lcd andcasing something bad is going to happen eventually. Please take a look at your t1's or t11's if my observation is valid and post them here on this thread.
soccerman is offline   Reply With Quote
Sponsored Links
Old Nov 4, 2004, 6:11 PM   #2
Senior Member
CyberShotNut's Avatar
Join Date: Sep 2004
Posts: 673

Yes, there is somewhat of a gap between the case and the LCD and on mine there is more of a gap on the right side than the left. There is a foam seal between the LCD and the case, so I don't see anything getting inside. Try sliding a piece of paper between the case and LCD and you can feel the foam seal.
CyberShotNut is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:33 PM.