Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Dec 9, 2004, 1:21 PM   #1
Junior Member
Join Date: Sep 2004
Posts: 3

I just purchased the Sony W1 from the store. I found that the outer lens had some white specks in the center. The specks are not shiny. They are not reflective when I inspect them with a torch. I tried to wipe them out with a lens cloth with water but they didn't go away.

I thought it's the problem of the lens so I exchanged the camera with another new one. Same problem but this time, the white specks appear near the corner. Tried to wipe them out but didn't help.

Do Sony cameras always have white specks on the lens or I am just not lucky?

Thanks very much
keithlo is offline   Reply With Quote
Sponsored Links
Old Dec 9, 2004, 10:30 PM   #2
Senior Member
Join Date: May 2004
Posts: 182


style="BACKGROUND-COLOR: #000000"My W1 didn't have white specks. I did see on one of these posts though that someone had a W1 with spots on it and it wasn't on the outer part on the lens but had spots on the CCD image sensor. Not sure if that's related.

style="BACKGROUND-COLOR: #000000"Go back to the store and make them give you another one and check it there.
kski is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:52 PM.