Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Jan 18, 2005, 10:34 PM   #1
Junior Member
Join Date: Nov 2003
Posts: 2

Have tried all ways to get decent photos, talked to technical support and according to them I am doing everything right! Photos are still garbage - my old Olympus 2100UZ makes this Sony thing - I won't grace it with the name camera - look like an old throwaway piece of junk. Has anyone managed to get ANY decent photos from one of these things - if so HOW did you do it. Please - any help will be gratefully appreciated.

The Bear
The Bear is offline   Reply With Quote
Sponsored Links
Old Jan 18, 2005, 11:11 PM   #2
Senior Member
CyberShotNut's Avatar
Join Date: Sep 2004
Posts: 673

A good friend of mine has a P73 and always gets excellent results with it. Try using it in "P" mode and adjust the settings to your preference. I have never personally usedthe P73, but my P93 gives me excellent, sharp pictures and I can't see the two being that much different.
CyberShotNut is offline   Reply With Quote
Old Jan 20, 2005, 12:12 PM   #3
Join Date: Jan 2005
Posts: 53

The Bear wrote:
Photos are still garbage
I'm not familiar with the P73 myself, but if you post one of your pictures here maybe someone can help you identify what's wrong. I think pictures get downsized when posted, so post a web-sized 100% crop if that will illustrate the problem better.

Have you tried looking at sample images from the P73 online, e.g. on this site or at Imaging Resource? These will give you an idea of what this model produces and might help you determine whether there's a problem with your camera, or whether your expectations are beyond the P73's capabilities.


Hope this helps,

davej is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:30 PM.