Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Feb 16, 2005, 5:29 PM   #1
Junior Member
Join Date: Feb 2005
Posts: 1

Just bought the Sony Cybershot DSC-P43, but cannot get it to function with my PC.

I'm running WinXP with AMD CPU and have used other (non-Sony) digital cameras with the PC without any issues whatsoever. In factI've used other Sony digital deviceswith the PC without problem.

I've tried all the obvious tricks - downloaded USB drivers, installed / re-installed various items, but still my PC will not pick up the presence of the camera via the USB port.

anyone any similar experiences / workarounds? it's perilously close to be returned for another brand if i can't fix it soon! thx
dwall is offline   Reply With Quote
Sponsored Links
Old Feb 16, 2005, 8:50 PM   #2
Senior Member
CyberShotNut's Avatar
Join Date: Sep 2004
Posts: 673

Try a different USB port. Win XP should detect the camera and automatically install the drivers. You shouldn't have to install the drivers from the CD. Make sure the USB setting in the setup menu is set to normal.
CyberShotNut is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 12:02 PM.