Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Sony

Thread Tools Search this Thread
Old Aug 7, 2006, 10:18 AM   #1
Junior Member
Join Date: Aug 2006
Posts: 1

I have a DSC-P92 that I have had for some time now. I bought an H-1 to replace it as the main family camera. I kept the 92 for personal use as I travel extensively and it's nice to have a smaller frame on the road. Anyway, just yesterday the 92 developed a problem. I turn it on and everything is fine. I snap the picture and it comes out all whited out, like there is fog on the lense (which there is not). There was no gradual change. One picture was perfect and the next it started this. The viewing screen looks fine when you look at it, although it is alternating between bright and normal a bit now. I tried changing memory sticks and batteries. Unfortunately that is the extent of my knowledge on this subject. I am assuming that something internal has gone bad and was looking for a little direction here. I really like having the camera with me while I travel with work and would like to fix it if possible and cost doesn't become prohibitive.

Does anyone have any idea what has happened?

Thanks in advance for any and all information,

bogietrim is offline   Reply With Quote
Sponsored Links
Old Aug 8, 2006, 2:46 AM   #2
Senior Member
CyberShotNut's Avatar
Join Date: Sep 2004
Posts: 673

Sounds like the beginning of the typical CCD issue. Sony will fix it for free if that's what it is, see this post: http://www.stevesforums.com/forums/v...mp;forum_id=28
CyberShotNut is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:12 PM.