Go Back   Steve's Digicams Forums > Post Your Photos > Sports & Action Photos

Reply
 
Thread Tools Search this Thread
Old Sep 20, 2006, 10:19 AM   #1
Super Moderator
 
Mark1616's Avatar
 
Join Date: Oct 2005
Posts: 7,397
Default

Hi All,

Not tried Motocross before so decided to give it a go last weekend.

KM5D with Sigma 70-200mm f2.8. Tv at 1/200s

It was really wet/dull and in the end my camera gave up working (need to get waterproof protection) so I only got about 150 shots before having to leave. It is happy again now though!.

What do you think? have a look here for more shots from the day.

Mark
Attached Images
 
Mark1616 is offline   Reply With Quote
Sponsored Links
Old Sep 20, 2006, 10:22 AM   #2
Super Moderator
 
Mark1616's Avatar
 
Join Date: Oct 2005
Posts: 7,397
Default

2
Attached Images
 
Mark1616 is offline   Reply With Quote
Old Sep 20, 2006, 10:23 AM   #3
Super Moderator
 
Mark1616's Avatar
 
Join Date: Oct 2005
Posts: 7,397
Default

3
Attached Images
 
Mark1616 is offline   Reply With Quote
Old Sep 20, 2006, 12:28 PM   #4
Member
 
Join Date: Jan 2006
Posts: 60
Default

Mark,

Nice captures! I looked at your galleries.....They are all very nice! Keep posting, its good to see a variety and you provide that!

Tamm
Tamsfam is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:17 PM.