Go Back   Steve's Digicams Forums > Post Your Photos > Sports & Action Photos

Reply
 
Thread Tools Search this Thread
Old Mar 2, 2008, 1:16 AM   #1
Senior Member
 
Join Date: Oct 2005
Posts: 189
Default

My first time using the Canon 1D MK3 for RC racing...I dunno if this camera had it's "issues" fixed...but part of me prefers the xxD series for rc shooting. I also got the "error 99" message after taking these photos

1


2


3


4


5


6

RadioControlGuy is offline   Reply With Quote
Sponsored Links
Old Mar 2, 2008, 9:14 AM   #2
Senior Member
 
Join Date: Jun 2004
Posts: 2,974
Default

Love it, love it, love it. It doesn't matter much what camera you use. You simply post some excellent shots of RC Racing. Always look forward to seeing your new posts.

Thanks,

Tom
vIZnquest is offline   Reply With Quote
Old Mar 2, 2008, 10:41 PM   #3
Senior Member
 
Join Date: Oct 2005
Posts: 189
Default

vIZnquest wrote:
Quote:
Love it, love it, love it. It doesn't matter much what camera you use. You simply post some excellent shots of RC Racing. Always look forward to seeing your new posts.

Thanks,

Tom
Thanks I appreciate the comments.

I was out shooting RC again today. However, I was using my trusty Canon 20d instead of the 1D MK3. Do you guys notice lower image quality with these set of pics?

Canon 20d + 70-200mm

1


2


3


4


5

RadioControlGuy is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 4:17 PM.