Go Back   Steve's Digicams Forums > Digicam Help > Studio Lighting, Flash & Other

Thread Tools Search this Thread
Old Jan 21, 2013, 3:19 PM   #1
Junior Member
Join Date: Jan 2013
Posts: 1
Default Neewer stobe lights

Hi not sure you have an answer but i'm going to ask anyway, I bought 3 of these Neewer 300DI lights, and I have a Canon 1100d t3 rebel camera, and I cannot get these lights to fire. I bought a canon hotshoe with a pc sync port, and set up my camera in manual mode, set the flash to sync at 1/200th in my camera..and nothing. So thinking the hot shoe was the probelm I ordered the Younguo RF-603c wirless flash trigger, got it all set up and NOTHING again. However when i pop-up the canon's on board flash and set the Neewer strobes to slave, they work.But i need this to work without my onboard flash...What do you think is the problem? btw: the Camers is brand new maybe 2 months old, and i've tried all 3 pc sync ports on all the strobes, thought maybe one may have had a bad pc sync port...i'm at a loss, any sugeestions? Thanks/Randy
P.S. flash options in camera all all greyed out, i think they only work with Canon Flashes, and I also disabled live view, which Canon says you have to in order to work with 3rd party flashes.
dana0069 is offline   Reply With Quote
Sponsored Links
Old Jan 24, 2013, 1:07 PM   #2
Senior Member
VTphotog's Avatar
Join Date: Mar 2005
Location: Extreme Northeastern Vermont, USA
Posts: 4,066

Do you have a way to try out a Canon hotshoe flash unit with your camera? I can think of several things that might be wrong, but confirmation that your camera works with a compatible flash on the hotshoe would answer a lot of questions.
I'm not a Canon user, and someone with brand experience may have a quick answer.

VTphotog is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:30 AM.

SEO by vBSEO 3.6.0 RC 2