Go Back   Steve's Digicams Forums > Digicam Help > Studio Lighting, Flash & Other

Thread Tools Search this Thread
Old Oct 10, 2002, 3:33 PM   #1
Junior Member
Join Date: Oct 2002
Posts: 1
Default old timer and new technoligy

I've got a oly c720 that I'm trying to figure out if I can get a set of Alien Bee's to work with. I'd like to get a set, but am unable to find out if the the on camera flash (in fill flash possibly) will trip the slaves and sync ok. Been out of portraits for 10+ and the new baby on the way has resparked my desire. I've got an old F1N system I know I can use, just like to know in advance if the digital is compatable.
glok27 is offline   Reply With Quote
Sponsored Links
Old Oct 10, 2002, 4:24 PM   #2
Senior Member
Join Date: Jun 2002
Posts: 385

The oly probably uses a pre-flash as do most digicams and that's a problem with most ordinary slaves. What happens with my Bees is they would actually fire tiwice very rapidly, once on the pre-flash and once for the exposure. Problem is this would give inconsistent results as the second flash may not have full power. If it was set to full power it wouldn't even give a second flash.

It can easily be solved with a digital slave. I used a Digi Slave SA-10 which did the trick. Wein has a digital version of the peanut slave that costs half as much though and doesn't require batteries. You will have to wire your sync cord to all the flashes as any of them still firing off the internal slave may see the camera's pre-flash. I don't need my digislave anymore but already sold it to a photographer in the same position as you.

padeye is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:33 AM.