Go Back   Steve's Digicams Forums > Digicam Help > Tips & Tricks

Thread Tools Search this Thread
Old Jul 18, 2004, 5:58 PM   #1
Junior Member
Join Date: Apr 2004
Posts: 11

I had a very upsetting experience today. On Friday, I tried to get my CF card read at Cosco to get pictures developed! The staff there tried several of their computers. None worked and could not read the card. They put my card in and out on three different computers and nothing happened. (I had previously dowloanded pictures through a card reader on my computer and thus know my card was fine). Staff finally said that they CF drive frequently does not work because people put wrong media in. I left the store and tried to take some pictures today. I had actually put in an old CF card and it worked. Then, I put the card in which Cosco attempted to read and the power on my camera would no longer turn on. I have tried replacing batteries and putting different CF card in. Nothing works. My camera won't turn on anymore! Meanwhile, my computer won't read the CF card anymore either. Lost all of my pictures. What is the proble here? What can I do?

After I went back to Cosco, they are reluctant to do anything. Waiting for a response. But after I left the store today, they seemed to start to suggest that in fact my cf card may have messed up their systems. They also say that frequently scandisk cf cards (which costco sells themselves) can have problems. But I have not had any problems with the card until after my visit to Cosco to attempt to develop my pictures!

danielswiss is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:14 AM.