Go Back   Steve's Digicams Forums > Post Your Photos > Transportation

Reply
 
Thread Tools Search this Thread
Old Nov 2, 2011, 4:25 PM   #1
Senior Member
 
Join Date: Sep 2011
Location: Bangor,North Wales
Posts: 3,731
Default Beetle

Caught this "Bug" by Bangor Pier.....
Was in a hurry- couldn't get more...
Attached Images
 
SIMON40 is offline   Reply With Quote
Sponsored Links
Old Nov 2, 2011, 6:24 PM   #2
Senior Member
 
Wingman's Avatar
 
Join Date: Dec 2003
Location: Hebron, Kentucky (northern Kentucky/Greater Cincinnati):KCVG
Posts: 4,315
Default

A neo- classic...i.e. not quite 1st generation, but vintage all the same. The diffused light works for this composition.
Wingman is offline   Reply With Quote
Old Nov 2, 2011, 6:33 PM   #3
Senior Member
 
Join Date: Sep 2011
Location: Bangor,North Wales
Posts: 3,731
Default

Roughly a 1967/68 model...
SIMON40 is offline   Reply With Quote
Old Nov 3, 2011, 10:14 AM   #4
Senior Member
 
Walter C's Avatar
 
Join Date: Nov 2004
Location: Huntington Beach, CA USA
Posts: 7,747
Default

A well preserved "game-changer" from a time of big automobiles and gas-guzzelling engines.
Walter C is offline   Reply With Quote
Old Nov 3, 2011, 10:45 AM   #5
Senior Member
 
Join Date: Sep 2011
Location: Bangor,North Wales
Posts: 3,731
Default

Indeed Walter C- definitely a "game changer"..... especially in the US..
SIMON40 is offline   Reply With Quote
Old Nov 3, 2011, 12:55 PM   #6
Senior Member
 
Join Date: Aug 2006
Location: Western Canada
Posts: 3,076
Default

Remember VW Beetles (Type 1) very well. First new car was a '61 VW 1200 Deluxe...then had a '64 VW Custom 1200...finally a '69 VW Deluxe Type 1 (Beetle)...1500cc engine.

Took the '69 to the dragstrip .....it ran through the 1/4 mile track @ 19.4 seconds...68.5 mph....back in 1970.
lesmore49 is offline   Reply With Quote
Old Nov 3, 2011, 7:26 PM   #7
Senior Member
 
Join Date: Sep 2011
Location: Bangor,North Wales
Posts: 3,731
Default

Lesmore49... you Hoon....lol... Dragging a 1500 Bug...!
SIMON40 is offline   Reply With Quote
Old Nov 3, 2011, 7:44 PM   #8
Senior Member
 
Join Date: Aug 2006
Location: Western Canada
Posts: 3,076
Default

Quote:
Originally Posted by SIMON40 View Post
Lesmore49... you Hoon....lol... Dragging a 1500 Bug...!

Also took it out on an ice racing, 'road' racing track for a few laps...on a river....frozen river..... My fun stopped when I stuffed it deep into a snowbank. My GF at the time (40 + years ago) wasn't amused...she was in the passenger seat at the time.
lesmore49 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 1:37 AM.