Go Back   Steve's Digicams Forums > Welcome Center > Welcome! Introduce yourself here

Thread Tools Search this Thread
Old Dec 23, 2009, 4:57 AM   #1
Junior Member
Join Date: Dec 2009
Location: Zamboanga City, Philippines
Posts: 4
Default hello steve's digicams

hello, buddies of the world, i'm new to digicams and i don't know how to fix a digicam's problem.,hope your forum will help me solve my problem..,i will post my problems later.., by the way, my real name is Erjoe, 23 male from Philippines, mabuhay!
sirnyor is offline   Reply With Quote
Sponsored Links
Old Dec 23, 2009, 5:45 AM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,370

Welcome to the forums. I posted some comments about your problem in the other thread you started:

PowerShot S5 IS: screen problem

I suspect you'll need to send it back to Canon for repairs from what I can tell from your problem description.
JimC is offline   Reply With Quote
Old Dec 23, 2009, 6:25 AM   #3
Super Moderator
Mark1616's Avatar
Join Date: Oct 2005
Posts: 7,396

Hi Erjoe and welcome to Steve's. I hope you get your problem resolved and do stick around and get posting some photos etc!!!
Mark1616 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:32 AM.