Go Back   Steve's Digicams Forums > Printers > Wide Carriage Inkjet

Reply
 
Thread Tools Search this Thread
Old Aug 14, 2005, 3:53 PM   #1
Junior Member
 
Join Date: Jul 2005
Posts: 6
Default

:?Purchased an r1800 three months ago. Worked fine for first month and half. Then started freezing up - not recognizing any print media. Talked with Epson three times. They sent email instructions, but did not solve the problem. Sent printer back through local dealer. Was just returned after two weeks. No comment on what they fixed. Same problem continues. Start to print, won't recognize print media. Turn printer off, turn on then it might print. What would you do?? any suggestion can you email me: dmiller787@netzero.net
dmiller787 is offline   Reply With Quote
Sponsored Links
Old Jan 9, 2006, 7:16 AM   #2
Junior Member
 
Join Date: Nov 2004
Posts: 23
Default

Don't wish to add to your disapointment but my brand new R1800 will not display the A3 roll feed option from Epson photo quicker despite having a roll of A3 inserted.

Sound like a similar problem to yours.

It would appaer that your printer is not fit for the purpose it was purchased for and therefore a full refund is in oder. (if you are in UK).
liningiv is offline   Reply With Quote
Old Apr 13, 2006, 7:15 AM   #3
Senior Member
 
Join Date: Dec 2005
Posts: 1,427
Default

I have had trouble with my epson r800 threw it out in the end, got canon printer, epson don't want to know once you bought your printer.

Alex
alex james is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:11 AM.