View Single Post
Old Jan 4, 2010, 2:44 PM   #3
Winfly
Junior Member
 
Join Date: Jan 2010
Posts: 4
Default

Quote:
Originally Posted by JimC View Post
Have you tried a different memory card in it, in case the card is corrupted?

You may also want to try changing your Transfer mode and see if that has any impact.

You'll find a Transfer Mode choice in your camera's Setup menus. I'd use USB Mass Storage versus PTP, as PTP can sometimes require the camera manufacturer's software to be installed to work with a given camera model.

If it still doesn't work, I'd suspect a bad USB Cable if it's doing the same thing with more than one memory card , and I'd reformat your memory cards prior to each reuse using the camera's menu choice for format, so that you'll always start out with a fresh File Allocation Table (just the way the camera expects it, since it's performing the format) to reduce the chance for File System Corruption.

You may want to consider using a card reader, too. I can't remember the last time I used a camera attached via a USB cable to transfer my images (it's been years since I've done it that way).
Thanks Jim.

I have tried different memory cards from your advise, but it still not works. I will try buy another USB cable, see it works or not.
Winfly is offline   Reply With Quote