View Single Post
Old Dec 18, 2007, 5:17 PM   #4
rinniethehun
Senior Member
 
Join Date: Mar 2005
Posts: 1,870
Default

" (second hand remember?)"

Yes, I remember. I also remember this:

"It cannot get charged. I plug it in and.. nothing happens. The small light on the back does not turn red and the battery remains empty."

Battery remains empty, to me means no charge...dead...no electricity coming out.

Then you said:

"When I'm focusing the lense does a strange noise until the camera focuses."

Now, all of a sudden, the dead battery is powering your camera. Any reason why I might be confused? And still am?

Anyway, assuming your battery had enough power to initially test your camera...the noise could just be the autofocus searching for a subject. Is the camera set to continuous autofocus?

When you attempt to charge the battery, could it be that 1. the battery is already fully charged? 2. The LED on the camera is burned out? 3. The battery is faulty and needs to be replaced? 4. The charger is faulty and needs to be replaced? 5. The contacts in either the charger or the camera (or both) are corroded and require cleaning?

Since it is a used camera, a discontinued model, which could already be close to two years old, with possibly thousands of pictures taken, I would bet the problem is most likely with the battery. If you know someone with the same camera, you could try their battery/charger. If not, buy a battery...or send the camera back from whence it came.

Good luck. Let us know what you come up with.

the Hun


rinniethehun is offline   Reply With Quote