Go Back   Steve's Digicams Forums > Digicam Help > Add-On Lenses

Reply
 
Thread Tools Search this Thread
Old Nov 16, 2006, 12:15 AM   #1
Junior Member
 
Join Date: Nov 2006
Posts: 2
Default

hi, i bought the canon rebel XT and whenever i take a picture theres always these greyish white blotches that show up on the pictures



as you can see where i circled, some of which you can see clearly the others you can see faintly. these blotches are on almost all my photos.

i have never took the lens off the camera before. i cleaned the front of the lens as well and still there were the blotches. on dark pictures you can see them clearly but on pictures with lots of things in the background its hard to see.

I bought this camera new and a couple of months later i started noticing these white blotches on my photos.

any ideas of which i can get rid of these blotches? or any ideas whats wrong with it?

sorry if this is in the wrong section please move it to its correct place.

im not really sure whats wrong with this but im pretty sure it might be the lens
photo888 is offline   Reply With Quote
Sponsored Links
Old Nov 16, 2006, 6:17 AM   #2
Senior Member
 
Join Date: Aug 2002
Posts: 851
Default

You are most likely looking at dust on the sensor. That means you need to clean your sensor.
amazingthailand is offline   Reply With Quote
Old Nov 16, 2006, 3:46 PM   #3
Junior Member
 
Join Date: Nov 2006
Posts: 2
Default

thanks i cleaned the sensor and its just like brand new
photo888 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:54 AM.