Go Back   Steve's Digicams Forums > Digicam Help > Batteries or Power Packs

Reply
 
Thread Tools Search this Thread
Old Jan 5, 2007, 12:04 AM   #1
Junior Member
 
Join Date: Jan 2007
Posts: 12
Default

Hi, I just got the lacrosse charger. So far it's great. At the very least it's told me that I've got some pooped out batteries, which I knew before, but at least it can pick out the obvious.

One thing I have to ask though is that one time I was charging some NiCds at the 1000mah rate, they were old batteries, and I was in a bit of a rush to get them charged. After a bit of time, I heard a pop come from the charger. (the same kind of pop when you short out a circut, but without the accompanying puff of smoke, just a pop) Sounded like a fuse blew or something. I immediately stopped and took everything out, and tride some test NiMh batteres. Every thing seemed to work again.

Now though I notice some humming coming from the unit. I don't know if it hummed before but it has an ever so slight hum now.

It seems to work well, I"m pretty happy. I charged some 2000mah aa's for my camera, and it seemed to have enough charge for a day for about 20-30 shots. Not really a great amount, but these old batteries have probably been abused in a 200mah cheap continuous charger for about a year or so.

Hope to be able to charge batteries with more controll and maximize the power capacity of my old batteries, and the new ones included with the charger.
fefrie is offline   Reply With Quote
Sponsored Links
Old Jan 6, 2007, 9:37 AM   #2
Senior Member
 
Join Date: Jul 2005
Posts: 358
Default

Hello Fefrie,

When NiCd cells vent, they sometimes give a pop along with it. Did you happen to notice any dampness or crystal growth at the + end?

My BC-900 does not hum. I am not sure what is going on with yours.

Tom
SilverFoxCPF is offline   Reply With Quote
Old Jan 7, 2007, 2:52 AM   #3
Junior Member
 
Join Date: Jan 2007
Posts: 12
Default

These Nicad cells were very old. So as soon as I heard the pop, I immediately took out the old cells and am now exclusively charging just nimh cells now.

style="BACKGROUND-COLOR: #000000"It's not worth risking my new charger with 4 year old cells. Not sure if there was any leakage or crystaline structure.

The hum is still there, I've read on other websites that it may be reduced when putiing the cells on a discharge cycle just before you remove them. I'll hang on I guess. I have a year before the warranty expires.

One thing that I did notice was that charging bay one and four sometimes work together. When bay one switches charging modes, it can sometimes take bay four with it. I notice that both charge elapse times are the same. It was really uncanny because bay one was an aa batery and bay four was an aaa battery.

I'll keep testing I guess.
fefrie is offline   Reply With Quote
Old Jan 7, 2007, 9:42 AM   #4
Senior Member
 
Join Date: Jul 2005
Posts: 358
Default

Hello Fefrie,

The BC-900 seems to suffer from a noisy power supply. People who have observed "crosstalk" between slots have noticed an improvement when they plug the charger into a surge suppressor.

Tom
SilverFoxCPF is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 3:15 AM.