Go Back   Steve's Digicams Forums > Digicam Help > Batteries or Power Packs

Reply
 
Thread Tools Search this Thread
Old Jul 24, 2002, 3:54 AM   #1
Junior Member
 
Join Date: Jul 2002
Posts: 2
Default Quest Q2 Charger problem

Had if for 3 months. Great charger and I do recommend it but this one has a problem.

Position 1 circuit always takes longer than the other 3 to switch to trickle mode.
I have rotated the batteries so a different batt is in pos 1 at each session with no difference. Average xtra time is 10-15 mins and has taken as long as 45.

I just emailed Quest to get their take and regarding warranty info. Anyone else hear of a problem?
DAVES is offline   Reply With Quote
Sponsored Links
Old Jul 24, 2002, 5:12 AM   #2
NHL
Senior Member
 
NHL's Avatar
 
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,547
Default

I believe your's is faulty then... On mine they randomly beep whichever battery is full first!

Also if the cover is closed the batteries are switched over to trickle charge sooner which is not a good thing (ie undercharged) leave the lid open also while charging...
NHL is offline   Reply With Quote
Old Jul 24, 2002, 10:51 AM   #3
Member
 
Join Date: Jun 2002
Posts: 61
Default

I also have the Quest Q2 charger, nice little charger.
I thought mine was doing that at first but it was a battery taking longer.
It does appear as though you have a problem with that one.
Hope Quest takes good care of you.

Good Day,
Steven
Steven H is offline   Reply With Quote
Old Jul 24, 2002, 1:53 PM   #4
Junior Member
 
Join Date: Jul 2002
Posts: 2
Default

Yeah I'm thinking there might be a problem with it too. It does charge and I do get a lot of pics with the batteries but the #1 circuit takes too long.

NHL - I have been charging with the cover up to reduce heat. You're right in that it does cause the batteries to charge longer.

I did hear from Quest today AND I ONLY E-MAILED THEM LAST NIGHT!! I received a response from the cust svc manager Wendy, who incidentally is the same person who responded to my request for product information prior to my purchase.
She responded immediately last time too and her excellent customer service (and the charger features) are the main reasons I bought the Q2. EXCELLENT PRODUCT SUPPORT and CS!!

She specifically asked me if I was charging with the cover up. She indicated that the time it takes to reach -Dv relies on the voltage and also a rise in ambient temperature (as NHL mentioned it keeps charging longer). She said I should try charging with the cover down and if I still have a problem to send the unit back for a replacement and that it should only take a few days to get me a new one.
I'm going to try cover down but think circuit 1 will still take longer and I'll probably end up sending it back for a new one.


Anyway, thanks for the replies.
Will let you guys know how it all turns out.

BTW -- This is my first post. Looks like a good forum. I can see it being very helpful in the future. -
DAVES is offline   Reply With Quote
Old Jul 25, 2002, 4:23 PM   #5
NHL
Senior Member
 
NHL's Avatar
 
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,547
Default

BTW have you check the simple stuff like the terminals on #1, are they clean?

It does seem like there's DT/dt feedback (ie difference when lid close/open), and the current is outflowing since the charge is completed on #1... -dV is harder to detect unless look at with a slow data recorder, since this is the falling slope of the voltage hump after a NiMh cell is charged.

[Edited on 7-25-2002 by NHL]
NHL is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:42 AM.