Go Back   Steve's Digicams Forums > Digicam Help > Batteries or Power Packs

Reply
 
Thread Tools Search this Thread
Old Jul 23, 2008, 5:09 PM   #1
Junior Member
 
Join Date: Jul 2008
Posts: 5
Default

Last night i put 2 of my new brought Ni-MH batteries into my Canon A590Is (the batteries were taken from the original box, could it be possbile that they were empty and needed to be recharged ?!) and the Lens started to come out but they stopped at half way and they remained that way , until i put some batteries and i could open and close the camera ok .
Could this be because the batteries were empty or something like that , or the camera suffered some kinda damage ?
DanyG is offline   Reply With Quote
Sponsored Links
Old Jul 24, 2008, 1:40 PM   #2
Senior Member
 
Bob Nichol's Avatar
 
Join Date: Apr 2003
Location: Eastern Ontario Canada
Posts: 822
Default

Rechargable batteries generally need to be charged before first use. All rechargable batteries will lose their charge with time even when not being used.

It is recommended to fully charge and discharge these batteries several times when new to "season" them properly.
Bob Nichol is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:17 PM.