Go Back   Steve's Digicams Forums > Digicam Help > Batteries or Power Packs

Reply
 
Thread Tools Search this Thread
Old Jun 4, 2010, 1:08 AM   #1
Senior Member
 
a-beginner's Avatar
 
Join Date: Dec 2007
Posts: 197
Default BC-900 Charger Mode Button Does Not Work

I've had a BC-900 charger for about 9 months now. Lately, whenever I try and change the charging mode by pressing on the Mode button, nothing happens - even after following the procedure in the manual on how to change modes. When new, there was no problem.

Anyone experience this and, if so, what did you do, short of sending it in for repair?

Thanks for your help.
a-beginner is offline   Reply With Quote
Sponsored Links
Old Jun 5, 2010, 2:49 PM   #2
Member
 
Join Date: Mar 2009
Posts: 46
Default

La Crosse BC-700/BC-900/BC-9009 Charger 'Meltdown' Reports

few reports with dropped mode button..
Egsise is offline   Reply With Quote
Old Aug 6, 2010, 12:04 AM   #3
Senior Member
 
a-beginner's Avatar
 
Join Date: Dec 2007
Posts: 197
Default

For those who may run into the same problem. I found the solution.

You just need to press down harder on the Mode button to get it to work. It looks like the switch is not that sensitive and requires a lot more pressure than normal.

Now the charger works as expected.
a-beginner is offline   Reply With Quote
Old Aug 14, 2010, 3:14 PM   #4
Member
 
Join Date: Mar 2009
Posts: 46
Default

Quote:
Originally Posted by a-beginner View Post
whenever I try and change the charging mode by pressing on the Mode button, nothing happens
Quote:
Originally Posted by a-beginner View Post
Now the charger works as expected.
Sounds like a high quality charger...
What if the button gets stiffer and stiffer and you need to use more and more power to press it?
Egsise is offline   Reply With Quote
Old Aug 14, 2010, 3:19 PM   #5
Super Moderator
 
Mark1616's Avatar
 
Join Date: Oct 2005
Posts: 7,397
Default

Pleased to say mine is fine and it is a stunning charger if not with the greatest switches.
__________________
Any problems with a post or thread please use the report button at the bottom left of the post and the team will help sort it out.

Have fun everyone!


See what I'm up to visit my Plymouth Wedding Photography
site or go to my blog.
Mark1616 is offline   Reply With Quote
Old Aug 15, 2010, 10:37 PM   #6
Senior Member
 
a-beginner's Avatar
 
Join Date: Dec 2007
Posts: 197
Default

Quote:
Originally Posted by Egsise View Post
Sounds like a high quality charger...
What if the button gets stiffer and stiffer and you need to use more and more power to press it?
So far after a lot of use, the pressure needed to activate the switch is still the same - just harder than you would expect. But an excellent product and worth the investment, specially when you consider that it can resurrect old batteries that you would normally throw away.
a-beginner is offline   Reply With Quote
Old Aug 19, 2010, 1:02 AM   #7
Member
 
Join Date: Mar 2009
Posts: 46
Default

Quote:
Originally Posted by a-beginner View Post
I've had a BC-900 charger for about 9 months now. Lately, whenever I try and change the charging mode by pressing on the Mode button, nothing happens - even after following the procedure in the manual on how to change modes. When new, there was no problem.
Quote:
Originally Posted by a-beginner View Post
So far after a lot of use, the pressure needed to activate the switch is still the same - just harder than you would expect.
What?
Egsise is offline   Reply With Quote
Old Aug 19, 2010, 11:25 PM   #8
Senior Member
 
a-beginner's Avatar
 
Join Date: Dec 2007
Posts: 197
Default

Quote:
Originally Posted by Egsise View Post
What?
What I meant is that from the start, when the unit was new, it took a lot more pressure than expected to operate the Mode switch/pushbutton.

Now, after more than a year of use, the Mode switch still requires the same amount of pressure to operate - more pressure than is normally expected.

Hope this clears this up.
a-beginner is offline   Reply With Quote
Old Aug 24, 2010, 3:44 AM   #9
Member
 
Join Date: Mar 2009
Posts: 46
Default

Quote:
Originally Posted by a-beginner View Post
I've had a BC-900 charger for about 9 months now. Lately, whenever I try and change the charging mode by pressing on the Mode button, nothing happens - even after following the procedure in the manual on how to change modes. When new, there was no problem.

Anyone experience this and, if so, what did you do, short of sending it in for repair?

Thanks for your help.
Quote:
Originally Posted by a-beginner View Post
What I meant is that from the start, when the unit was new, it took a lot more pressure than expected to operate the Mode switch/pushbutton.

Now, after more than a year of use, the Mode switch still requires the same amount of pressure to operate - more pressure than is normally expected.

Hope this clears this up.
Quote:
Originally Posted by a-beginner View Post
For those who may run into the same problem. I found the solution.

You just need to press down harder on the Mode button to get it to work. It looks like the switch is not that sensitive and requires a lot more pressure than normal.


Now the charger works as expected.
What?
You forgot how the charger works?
How often you use it, once every 6 months?
Egsise is offline   Reply With Quote
Old Aug 24, 2010, 11:14 AM   #10
Super Moderator
 
Mark1616's Avatar
 
Join Date: Oct 2005
Posts: 7,397
Default

Egsise, I think we can leave this subject alone now, much better than trying to start an argument or anything similar.
__________________
Any problems with a post or thread please use the report button at the bottom left of the post and the team will help sort it out.

Have fun everyone!


See what I'm up to visit my Plymouth Wedding Photography
site or go to my blog.
Mark1616 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:30 AM.