Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Canon (https://forums.steves-digicams.com/canon-21/)
-   -   Can't Download Images (https://forums.steves-digicams.com/canon-21/cant-download-images-118901/)

smartin Apr 7, 2007 8:51 PM

Today I had my first problem downloading images from my new S3IS. I see similar problems have been discussed here so hopefully this adds to the knowledgebase.

Last night I shot my SanDisk 2GB card to capacity with full-size JPGs and a few videos. About 190 images (including about 10 minutes of video) were timestamped 6-Apr-2007, while a dozen more JPGs and another 4 minute video rolled over to 7-Apr-2007.

When I downloaded my goodies, only the 6-Apr stuff transferred. I realized the omission, unplugged and replugged the camera, and attempted to use the Canon utility to download the remaining "new" images. After a second or two, I get this error "lost communication with the camera" or some such. I tried several times, same result.

Plan B: Plug the SD card into a card reader and let my wife's PC read it. Her PC can't read the card at all. Her PC is practically new.

Plan C: Plug the camera in again, but this time skip the Canon utility and browse to the camera device in Windows Explorer. I can see all the JPGs and the AVI. Copy... paste... all the JPGs come through but not the AVI.

Plan D: Plug the camera in again, but this time use the camera itself to select what to transfer. The AVI finally makes it.

OK with all images successfully saved I did a low-level format on the card, but this has really shaken my confidence. Some folks are reporting unwritable cards, fussed-up FAT tables and the like, and I have now had to wrestle for way to long to get what is rightfully mine off the card.

Moreover, now that I have all the images, my wife's PC can't view them all ("unrecognized or missing file header"). This is really wierd... about 1/2 the pics are unreadable on her machine (which is much newer than mine). There doesn't seem to be any rhyme or reason to this. I used Irfanview to resave all the JPGs and she can now read them all.

Anyway, thanks for listening to my rant. If any of this makes sense to anyone I'd appreciate your advice.

Next weekend I will try shooting up this card again. Hope it works ok.

Bingee Apr 7, 2007 11:05 PM

Did you happen to purchase the Scandisk from an EBAY seller ?
most of them are selling counterfeit Scandisk cards, and folks
are having simular trouble with them

Bingee

smartin Apr 8, 2007 7:08 PM

I bought my card from the same store (a well known electronics chain in the US) as the camera. Thanks for the info though!

Tullio Apr 9, 2007 10:45 AM

Here we go again...the usual "blame it on the card" thing. The S2 generated dozens of threads related to the"memory card error" issue. I had an S2 myself and sold it because of this (and other) issues. I haven't followed the S3 as closely since I do not owe one but I've already come across a significant number of threads discussing memory issues with it. Although I believe SD cards do fail (specially the more obscure brands), I see their failure being a much less of an issue with other cameras than with the Canon S series. I have 4 cameras that take SD cards. I use ACP-EP cards (1, 2 and 4 Gb) and they never ever failed on any of my cameras (Panasonic LZ2, Pentax K100, Nikon D40, Kodak DX6440) but the 1gb card did fail on my S2.

smartin Apr 9, 2007 6:22 PM

Tullio wrote:
Quote:

Here we go again...the usual "blame it on the card" thing. [snip]
I'm not blaming anything yet, but my own experience is limited to just two cameras:, and both are Canons. The old camera used CF, and I had a bad CF card once. However, I was able to blame the card in that case because it was cut & dried. Here it's not for sure.

Thanks much for the info!

Tullio Apr 9, 2007 7:41 PM

I know, smartin. I really did not mean to sound harsh or anything. It's just thatit seemsmemory card issues occur much more often with Canon cameras than any other brand (at least I don't come across very many threads related to such a problem with other camera brands). I do agree that every memory card errorhas a fifty-fifty chance of being the card or the camera (specially if the card is one of those cheap unknown brands). I guess I've been very lucky with my cards and cameras (except for the S2)so far!

smartin Apr 11, 2007 6:56 PM

Tullio wrote:
Quote:

I know, smartin. I really did not mean to sound harsh or anything. It's just thatit seemsmemory card issues occur much more often with Canon cameras than any other brand (at least I don't come across very many threads related to such a problem with other camera brands). I do agree that every memory card errorhas a fifty-fifty chance of being the card or the camera (specially if the card is one of those cheap unknown brands). I guess I've been very lucky with my cards and cameras (except for the S2)so far!
It's no problem Tullio - I really do appreciate your input.

I am concerned to learn of this apparent memory card problem now, assuming it really is a problem with the camera or firmware. I did many hours of research before I invested in this camera. I knew about its photographic quirks, but I did not come across complaints related to corrupted memory cards. In fairness, I didn't look for that problem either. If there truly is a firmware problem I can hope Canon will correct this and make an update available.

Hopefully I will not encounter show-stopping problems. I will hope for the best!

Tullio Apr 11, 2007 8:31 PM

I hope so too. It's no fun to invest on a piece of equipment that is not reliable. For that reason, I'd strongly suggest you carry multiple small size cards (1 gb max). It seems that the camera has more problems handling larger cards than smaller ones.


All times are GMT -5. The time now is 7:59 AM.