Steve's Digicams Forums

Steve's Digicams Forums (https://forums.steves-digicams.com/)
-   Canon (https://forums.steves-digicams.com/canon-21/)
-   -   G3 and Win XP communication problem (long) (https://forums.steves-digicams.com/canon-21/g3-win-xp-communication-problem-long-6435/)

John Davies Jan 22, 2003 1:24 PM

G3 and Win XP communication problem (long)
 
:?:
I apologize if this has been answered recently - I am new here and couldn't find anything using Search.

I have a new G3 which functions perfectly using my Windows 98 (TWAIN driver) pc. I can't get any computer to camera communication on my Windows XP (WIA driver) pc. I get two errors:

The "Select program to launch for this action" window contains no listings - it is completely blank.

A few minutes after I close that window I get a Windows error: "Generic Host Process for Win32 Services has encountered a problem and needs to close". This refers to svchost.exe, about which I am only vaguely familiar.

I have two main USB 2.0 ports, and the only other USB device is a mouse. Switching the cable to the other USB port makes no difference. I do have a USB to printer adapter cable, which is currently unplugged. It did NOT require installing a USB driver, so I don't think this is contributing to the problem, but I may be wrong.

Uninstalling and reinstalling the driver and software makes no difference.

The camera appears in Device Manager and the “device is functioning normally”.

ZoomBrowser does not find the camera - it says the "camera has no images or the folder is empty".

I tried changing the communcations mode form Normal to PTP, and Win XP Explorer still can't find the data, though it does show the camera as being connected.

I spent an hour on the phone with Canon, and while the tech was polite and efficient, all he did was have me repeat everything I had already tried.

I know the camera, cables and Win 98 software all work. I suspect a Win XP problem associated with the USB or with the WIA driver.

I was going to try running Breeze Systems' Downloader utility for the heck of it, but it currently does not support the G3.

Can anyone help me? Please?

Jazgord Feb 1, 2003 2:23 PM

I had a problem with my G3 and wxp also. I went to canon web site and downloaded the wia driver zip file. Unzipped file and installed the driver software. Connected the camera to the computer and it worked.

cfhplumb Feb 12, 2003 8:07 PM

I have the same problem with my power shot g3. I have windows ME. Sometimes it works and sometimes it does not. I tried uninstalling and reinstalling the driver. Removing other devices on the usb port. I downloaded the driver off the web site, it worked once. Then I had the same problems. I somehow manage to get the pictures off my camera but it takes a long time.

rkuite Feb 23, 2003 7:10 AM

My G3 and Windows XP has this EXACT problem on my Dell Laptop when plugged in directly to the back of the Laptop (undocked profile). The interesting thing is that it works flawlessly when the laptop is in its docking station (docked profile).

I haven't troubleshooted further because most of the time I download images when the laptop is docked. I will play around with the undocked condition and see if I can turn anything up.

There is a new Beta version of Breeze downloader available that does support the G3 but I suspect the behavior woul dbe the same because the problem is at an OS level (OS <--> driver <--> G3)

Stay tuned.
-Randy


All times are GMT -5. The time now is 1:27 PM.