Will newer versions of Canon software work with older camera