Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Sep 30, 2006, 10:18 PM   #1
Member
 
Join Date: Sep 2006
Posts: 98
Default

Does anyone know why the 580EX flash doesn't fire in Av or Tv modes using a Rebel XT?

It fires just fine in other modes with nicely exposed images but I don't see anything in the manual stating it wont work in Av or TV modes using E-TTL......anyone know what I can do to get auto flash using Av or Tv modes?

Thanks guys,

[email protected]
SteveNunez is offline   Reply With Quote
Sponsored Links
Old Oct 1, 2006, 11:18 AM   #2
Senior Member
 
Imacer's Avatar
 
Join Date: Jan 2004
Location: Juneau, Alaska
Posts: 474
Default

Steve i have the same problem and have the same camera.
Imacer is offline   Reply With Quote
Old Oct 1, 2006, 5:38 PM   #3
Senior Member
 
Ewok's Avatar
 
Join Date: Oct 2004
Posts: 142
Default

Maybe it has something to do with the sync shutter speed? Try setting custom function 3 to force Av mode to sync at 1/200.
Ewok is offline   Reply With Quote
Old Oct 1, 2006, 10:15 PM   #4
Senior Member
 
BoYFrMSpC's Avatar
 
Join Date: Apr 2005
Posts: 339
Default

I don't think that's the problem. I've tried tinkering with a bunch of the custom functions and the only time I would get my 580ex NOT to work on my XT was when I switched the flash mode to TTL. But in that case, it wouldn't work, whatsoever.

It's weird, when I got my 580 it worked just "out-of-the-box". Did you buy it used? Maybe you should try another one...

But I just thought about this now.... like literally now... Before you try another flash, perhaps you should make sure your firmware is the latest version (1.0.3)

Here's the website where you get it.
http://web.canon.jp/Imaging/eosdigit...irmware-e.html

It might work, it might not... sorry that I couldn't help much
BoYFrMSpC is offline   Reply With Quote
Old Oct 2, 2006, 5:56 AM   #5
NHL
Senior Member
 
NHL's Avatar
 
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,547
Default

When you turn the 580EX on does the camera automatically change the shutter speed to an X-sync speed in Av or Tv?

How about the flash icon in the viewfinder? Does it lit-up when the flash is ready in either mode?
NHL is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 8:22 PM.