Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Oct 6, 2006, 1:30 AM   #1
Senior Member
 
Join Date: Jan 2006
Posts: 146
Default

I wanted to buy a set ofextension tubes for my 350 Rebel, but the Kenko I tested not fitted! On the package was written "for Canon EOS" (and nothing else!!!) - tubes can be attached to body but my kit lens didn't match to the tube.The seller told me that these tubes are not for EF-S mount.

I think my second lens - Sigma 70-300 APO DG Macro - also will not match with tubes I tested with 17-55 EF S lens.

Please tellme what is the exact type of the Kenko tubes that could be fitted to 350 Rebel.

Thank you!
vidiac is offline   Reply With Quote
Sponsored Links
Old Oct 6, 2006, 8:23 AM   #2
NHL
Senior Member
 
NHL's Avatar
 
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,547
Default

It should fit the Sigma 70-300 APO DG Macro - This is an EF mount and not EF-s!
-> you can always 'mod's the EF-s into an EF mount
http://www.bobatkins.com/photography...s/efs-10d.html

... or get the correct EF-s tube
NHL is offline   Reply With Quote
Old Oct 6, 2006, 11:45 AM   #3
Senior Member
 
AlpineMan's Avatar
 
Join Date: Mar 2005
Posts: 357
Default

Yup...I've seen 17-85mm IS, 10-22, and 18-55 EF-S lenses modded to EF mounts...but not the 17-55mm IS. if I had this lens though, I wouldn't do it...the possibility of a thousand bucks going down the drain is too much for my blood.
AlpineMan is offline   Reply With Quote
Old Oct 7, 2006, 4:46 PM   #4
Senior Member
 
Join Date: Jan 2006
Posts: 146
Default

On Monday I will find if at least Sigma will fit!!
vidiac is offline   Reply With Quote
Old Oct 7, 2006, 6:37 PM   #5
Member
 
Join Date: Oct 2004
Posts: 84
Default

I own both the 300d and 350d dRebel and the Kenko Extension Tube Set and the kit lenses do not work with the Kenko. All other (Canon, Sigma & Tamron) EF lense do work with te tubes, no need to modify anything.
roy123 is offline   Reply With Quote
Old Oct 14, 2006, 12:30 AM   #6
Senior Member
 
Join Date: Jan 2006
Posts: 146
Default

It is right - Sigma 70-300 can be attached to Kenko "for EOS".

Roy 123,

I solved the problem you have - just enlarge the hole in one Kenko tube and the 18-55mm kit lens will fix to the tube. If you want I can post the picture of the tube after this "adjustement". It works OK and now is possible to use the AF (Sigma couldn't focus automaticaly with tubes). I modified the 12mm tube and the results are as I aspected and even better regarding the acuracy of focus on subject.



vidiac is offline   Reply With Quote
Old Oct 14, 2006, 9:04 AM   #7
Member
 
Join Date: Oct 2004
Posts: 84
Default

vidiac, my solution was a bit different than yours...i sold one of the 'kit lenses' and the other is stored deep in one of my archive boxes...i haveone kit lens,but will retain one of the two i had in case i decide to sell one of the cameras and then i'll include it. thanks for your suggestion though...
roy123 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:40 AM.