Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Jan 12, 2007, 6:27 PM   #1
Junior Member
 
Join Date: Nov 2006
Posts: 17
Default

Afterless than one month of use , my pop up flash on my Canon 30D would not pop up. I had been using my EX Speedlight most of the time but sent it back for replacement. I do pick up the camera by holding the flash , but I can't imagine this would damage it. Has anyone else had this problem? I had my canon film camera for 17 years problem free. After what I just spent on the 30D, I hope this was only a fluke.

One more Question: I bought the 17-85 is kit lens with the camera. Thinking about adding a lens like a 70-200 2.8. What do you believe to be the best value? Is getting a stabilized lens for general use a wise idea. (meaning I don't want to carry a tripod around). Would appreciate a specific suggestion.



Thanks Dean:O
bestofdean is offline   Reply With Quote
Sponsored Links
Old Jan 12, 2007, 9:04 PM   #2
Junior Member
 
Join Date: Jan 2007
Posts: 13
Default

Did you try pressing the Flash button on the left side of the lens mount?

Cuz, I'm thinking maybe you broke or lost the spring that props up the flash.
CptOfGondor is offline   Reply With Quote
Old Jan 13, 2007, 3:57 PM   #3
Junior Member
 
Join Date: Nov 2006
Posts: 17
Default

I did press the button as well as try to use the auto mode in low light situations where it ought to have poped up.
bestofdean is offline   Reply With Quote
Old Jan 13, 2007, 5:56 PM   #4
Member
 
Join Date: Feb 2006
Posts: 90
Default

If you can afford it, get the IS. At times of low light when flash isn't on, some of my results have been sensational. (70mm - 200mm f2.8L IS)
Gypsyrico is offline   Reply With Quote
Old Jan 13, 2007, 5:56 PM   #5
Member
 
Join Date: Feb 2006
Posts: 90
Default

Gypsyrico is offline   Reply With Quote
Old Jan 13, 2007, 7:16 PM   #6
Super Moderator
 
peripatetic's Avatar
 
Join Date: Nov 2004
Posts: 3,599
Default

The flash on my 20D is sometimes quite sticky and won't pop up.

I just pull it up with my fingernail, and then it seems to be ok for a while again.
peripatetic is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:03 AM.