Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Feb 22, 2007, 5:21 PM   #1
Senior Member
 
Trique Daddi's Avatar
 
Join Date: Apr 2004
Posts: 282
Default

I had an unusual series of events today and they probably aren't related. My 20D is a little over a year old. I have a 70-200mm 2.8 Canon lens,the 18-55mm Canon kit lens,a Sigma 17-70mm lens and the Canon 1.8. I recieved a 2x Canon teleconverter that I ordered to use with the 70-200 and put it on as instructed and my shutter locked. I was in TV-shutter priority when it happened. Since then none of the other lenses will work in any of the cameras shooting modes (tried Manual,AV...). This camera has never locked up. I shot with one with older firmware that did and after removing the battery it would return to proper functioning. I called Canon and tried removing both the date and time battery along with the camera battery to no avail. The lenses focus and other camera functions work. They told me to have it repaired. Fortunately, I have an extended warranty so we will see have smoothly that works.I am going to Circuit City where I purchased it tomorrow.

I have never used a Teleconverter but I don't think I am missing anything simple. I checked all of my settings and didin't see anything that I inadvertently changed.

Trique Daddi


Trique Daddi is offline   Reply With Quote
Sponsored Links
Old Mar 8, 2007, 10:22 PM   #2
Senior Member
 
Trique Daddi's Avatar
 
Join Date: Apr 2004
Posts: 282
Default

Just an update. My warranty was serviced by Precision Camera. They sent me a shipping container on the 26th of Feb. and I had my camera back on the 6th of March. My extended warranty is through Circuit City. The shutter was repaired and the power on/off switch was repalced. I took to our local zoo that afternoon and was very pleased with the results.

Hope no one will need this but From the one experience I recommend them!

Trique Daddi
Trique Daddi is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 7:21 AM.