Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Canon EOS dSLR

Reply
 
Thread Tools Search this Thread
Old Dec 8, 2007, 9:30 AM   #1
Senior Member
 
thekman620's Avatar
 
Join Date: Feb 2004
Posts: 6,084
Default

Hi everyone,

I usually shoot a lot of outdoors - wildlife and some landscapes. When I change lenses (all the lenses are Canon L lenses), the camera usually locks up, and will not fire. The top lcd will be on, and AF works, but the shutter won't fire. I then shut the camera off - remove the battery, and reinstall it. I have to do this sometimes up to 3 times before it will function again. Once the camera is functioning, the problem doesn't occur again until I change lenses, and then the whole process repeats itself. Has anyone else encountered this problem?

I have cleaned the contacts of the batteries and the camera, and also the lenses I use (3 of the lenses are brand new). I also have used 3 different batteries with the same results. I'm kind of stumped here, and no one I've asked at camera stores or even Canon repair centre when I called them had any kind of an answer. I guess I'll end up sending it in for repair, but it would be nice to know if this is an inherent problem with the 30d...

Thanks........Don


thekman620 is offline   Reply With Quote
Sponsored Links
Old Dec 8, 2007, 10:32 AM   #2
Senior Member
 
hgernhardtjr's Avatar
 
Join Date: Nov 2004
Posts: 516
Default

No, it is not an inherent problem. I never have problems changing lenses.However, while Ivirtually alwayschange lenses with the power on (Canon L, Sigma, Tokina, etc.),I have seen where others have recommended changing lenses with the power off in order to avoid problems.

You might try changing the lenses with the power off and see if that helps.

Nonetheless, I personally could not accept having to turn the camera off for each lens change, especially when needing to do a fast change.Were the camera mine, I would have Canon look at it.
hgernhardtjr is offline   Reply With Quote
Old Dec 8, 2007, 11:55 AM   #3
Super Moderator
 
peripatetic's Avatar
 
Join Date: Nov 2004
Posts: 3,599
Default

What lenses are you using?
peripatetic is offline   Reply With Quote
Old Dec 8, 2007, 12:15 PM   #4
Senior Member
 
Join Date: Oct 2005
Posts: 1,105
Default

when it locks up can u check if the shutter is fully open or close. i had a similar problem with my 5D, sent it to canon andthey replaced the shutter
nymphetamine is offline   Reply With Quote
Old Dec 8, 2007, 1:12 PM   #5
Senior Member
 
thekman620's Avatar
 
Join Date: Feb 2004
Posts: 6,084
Default

Thanks for some insight everyone. I always turn the camera off when changing lenses. The lenses I'm using are the 300f/4L IS, the 70-200L f/4 IS, and 24-70L f/2.8. Doesn't matter what combo I use or anything of the sorts. It just won't fire after changing. The orange indicator light that flickers when you turn on the camera doesn't light up when I turn it back on after a lens change. So I unload the battery, and reload it and until the orange light flickers on the battery being reinstalled..it doesn't fire.......Don
thekman620 is offline   Reply With Quote
Old Dec 8, 2007, 3:58 PM   #6
Senior Member
 
Sabine's Avatar
 
Join Date: Jun 2007
Posts: 701
Default

Don, I have been using my 30D forover 1 1/2 years andnever had that happen with mine. I usually turn the camera off when changing the lens but sometimes I forget and change it with the power still on. Hope you get it straightened out.


Sabine is offline   Reply With Quote
Old Dec 8, 2007, 4:43 PM   #7
Super Moderator
 
peripatetic's Avatar
 
Join Date: Nov 2004
Posts: 3,599
Default

Sounds like it needs a trip to the service centre.
peripatetic is offline   Reply With Quote
Old Dec 8, 2007, 5:05 PM   #8
Senior Member
 
Join Date: Oct 2005
Posts: 1,105
Default

The orange indicator light that flickers when you turn on the camera doesn't light up when I turn it back on after a lens change

ok

the power sources for the 30D include

• Lithium-Ion BP-511A rechargeable battery (supplied & charger)
• Supports BP-511 / BP-511A / BP-512 / BP-514
• CR2016 Lithium battery (date/time backup)
• Optional AC adapter

Can u replace the CR2016 battery and check. Also Can u try changing the lens with a NEW CF card.


nymphetamine is offline   Reply With Quote
Old Dec 8, 2007, 5:22 PM   #9
Senior Member
 
thekman620's Avatar
 
Join Date: Feb 2004
Posts: 6,084
Default

nymphetamine wrote:
Quote:
The orange indicator light that flickers when you turn on the camera doesn't light up when I turn it back on after a lens change

ok

the power sources for the 30D include

• Lithium-Ion BP-511A rechargeable battery (supplied & charger)
• Supports BP-511 / BP-511A / BP-512 / BP-514
• CR2016 Lithium battery (date/time backup)
• Optional AC adapter

Can u replace the CR2016 battery and check. Also Can u try changing the lens with a NEW CF card.

Oh yeah. I forgot to inform everyone, I already changed the CR2016 battery. It made no difference. I have tried fresh cards too, and nope....still does it. I guess I'm going to have to send it in for repairs. Hope their service is fairly quick...thanks for the help everyone. I was hoping someone else had experienced this, but it just looks like I've got a unit with something uniquely wrong to itself, and not a common problem........cheers.....Don
thekman620 is offline   Reply With Quote
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:18 PM.